Standardized test suite names for improved consistency;
Introduced a new set of utilities to streamline test suite definitions, including functions like `logTestName()`, `parseScriptFromString()`, `parseScriptFromFile()`, `viewOutputPort()`, `areFilesEqual()`, `registerTemporaryFunctor()`, and others;
Added utilities to enhance exception handling in tests: `TEST_[CHECK|REQUIRE]_NO_THROW`, `TEST_[CHECK|REQUIRE]`, `TEST_[CHECK|REQUIRE]_EQUAL`, `TEST_[CHECK|REQUIRE]_CLOSE`, `TEST_CHECK_LOOKUP_TABLE_CONTENT`, `TEST_CHECK_LAYER_CONTENT`, etc;
Renamed `Test::runScript()` for clarity;
Removed unnecessary includes to optimize the codebase;
Refactored the structure of test files for better organization;
Reformatted test files for consistent styling;
Some other miscellaneous changes.